Upgrade To Premium Glitch


#1

@grant

The upgrade to premium button has disappeared on new owned domain listings.

I submit my names to Basic Plus, then update everything and ‘upgrade to Premium’. That way, if it’s rejected it’s already where I need it to be.

Without this option, we have to submit to Premium, then if it’s rejected, submit it again to Basic Plus (twice the work, and doing it just once takes long enough).

Can you fix this please?

Many thanks


#2

I’m so glad you brought this up, Able! I didn’t even notice that! It definitely needs to be fixed. It is really useful to sub names the way that you are doing it.


#3

Thank you @grant It’s back today. I don’t know if you fixed it or if it was a glitch that worked itself out.


#4

Out of topic, @AbleBrands, based on ur experiences which one is more profitable and better, creative owned or sh owned marketplace? Thank you.


#5

@fxpreneur I can’t really answer this because I don’t have many SH owned domains. Most of my domains I’ve owned for years (some over 10 years!).


#6

Hi, All. Yes. This is now fixed. Thanks for reporting the issue :slight_smile: