Clicking Submit but not Submitting

I have been trying to submit some couple names for a client that asked for a business name for his business. I spent hours calculating and brainstorming some couple names. Lucky for me, most of the names domain are available but then i try submitting my entry after i first ensured my secure connection to the INTERNET because that has once stopped my name from getting submitted. I have been clicking submit to no avail. It kept saying field cant be empty and trust me i checked there were no empty field at all.
So i went straight away to A NEW CONTEST and i just tried testing if the same issue would occur. Yes it did, it was telling me FIELD CAN’T BE LEFT EMPTY even though there was no empty field. Contest ends in few hours time. Please help me

@Femlogix try to refresh your browser, If it still doesn’t work ask SH via the blue button and they will help you.

you have to put a name in some of them as well as the domain I noticed

@Nelmag How do i ask SH?

All field are filled, no field appears empty at all

Click the blue button at the bottom right corner of your screen. That will open a chat box with a Squadhelp representative.

1 Like

@Nelmag I just refreshed my browser, and re entered my entry. But it’s giving me the same feedback.
FIELD CAN’T BE EMPTY. There are no empty fields @sh

@ALDaisy1 Thank you so much

1 Like

I’ve had that happen often. If refreshing didn’t work, I’ve even used a new browser and that has helped. Ive also highlighted and cut my name from the Domain Entry space and hit enter, then it says “Domain Empty” and I paste my entry back in, and it usually works. Weird.

1 Like

Hi. If your keyboard layout ain’t american that same happens

Me too, same here. I never said anything about it because I am using such an old browser on one of my computers that I figured it was my fault. LOL.

1 Like

when that happens just cut your submission close the browser then paste it and resubmit… happens to me alot

1 Like

I blue bubbled it originally and was suggested using a new browser, and it worked. But, it happens so often, I now just click…cut…enter…paste. It works just as well LOL. DEF agree I thought it was the operator too!

1 Like

This is a problem that comes and goes for me, too. Clearing the cache, etc. solves the problem for a while, but I agree, cut-and-paste is the quickest work-around.


We are figuring this out though aren’t we?! pats on shoulders Nothing will stop us from entering our latest genius ideas! :bulb: We will find a way!


@Kelvinrhs…on any screen (although not here in the forum) look to your lower right hand corner of the screen. The blue button is there to ask questions, etc…

1 Like